  <!doctype html>

<html lang="en" class="bni articlePage ">
    <head>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
				<title>Bruce Curtis Drennan - Cordele Dispatch | Cordele Dispatch</title><link rel="preload" href="https://www.cordeledispatch.com/wp-content/themes/2021-cordele-child/media/img/brand/logo-white-cordeledispatch.png" as="image" /><link rel="preload" href="https://www.cordeledispatch.com/wp-content/themes/2021-cordele-child/media/img/brand/logo-white-mobile-cordeledispatch.png" as="image" /><link rel="preload" href="https://www.cordeledispatch.com/wp-content/themes/2021-bni/media/img/Search_icon-black.png" as="image" />

        <meta name="viewport" content="width=device-width, initial-scale=1">

        
        <link href="https://www.cordeledispatch.com/wp-content/themes/2021-bni/style.css?1656103127" as="style">

				        <link href="https://cdn.jsdelivr.net/bxslider/4.2.12/jquery.bxslider.css" rel="stylesheet">
				<link rel="stylesheet" href="https://www.cordeledispatch.com/wp-content/themes/2021-bni/media/css/normalize.css?1655930780" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.cordeledispatch.com/wp-content/themes/2021-bni/style.css?1656103127" />

        <script defer="defer" src="https://www.cordeledispatch.com/wp-content/themes/2021-bni/media/js/vendors/modernizr-2.6.2.min.js?1655930780"></script>

				<link rel="Shortcut Icon" type="image/ico" href="https://www.cordeledispatch.com/wp-content/themes/2021-cordele-child/media/img/brand/favicon-cordeledispatch.png">

				
				<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v19.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<link rel="canonical" href="https://www.cordeledispatch.com/2022/06/24/bruce-curtis-drennan/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Bruce Curtis Drennan - Cordele Dispatch" />
	<meta property="og:description" content="Bruce Curtis Drennan, (The Great Santini, Bossman, Grandpa, Dad, Brucey) died on Thursday, June 23, 2022 after threatening his children he would do so for quite some time. Funeral services to celebrate his truly unique and full life will be held on Sunday, June 26, 2022 at 2:00 p.m. in the chapel of Rainey Family [&hellip;]" />
	<meta property="og:url" content="https://www.cordeledispatch.com/2022/06/24/bruce-curtis-drennan/" />
	<meta property="og:site_name" content="Cordele Dispatch" />
	<meta property="article:published_time" content="2022-06-24T20:43:05+00:00" />
	<meta property="og:image" content="https://www.cordeledispatch.com/wp-content/uploads/sites/56/2020/05/facebook-cordeledispatch.png" />
	<meta property="og:image:width" content="1200" />
	<meta property="og:image:height" content="630" />
	<meta property="og:image:type" content="image/png" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Chris Lewis" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="4 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.cordeledispatch.com/#website","url":"https://www.cordeledispatch.com/","name":"Cordele Dispatch","description":"Cordele Dispatch","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.cordeledispatch.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https://www.cordeledispatch.com/2022/06/24/bruce-curtis-drennan/#webpage","url":"https://www.cordeledispatch.com/2022/06/24/bruce-curtis-drennan/","name":"Bruce Curtis Drennan - Cordele Dispatch","isPartOf":{"@id":"https://www.cordeledispatch.com/#website"},"datePublished":"2022-06-24T20:43:05+00:00","dateModified":"2022-06-24T20:43:05+00:00","author":{"@id":"https://www.cordeledispatch.com/#/schema/person/434626653d9c0d573eee2a31cd093dec"},"breadcrumb":{"@id":"https://www.cordeledispatch.com/2022/06/24/bruce-curtis-drennan/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.cordeledispatch.com/2022/06/24/bruce-curtis-drennan/"]}]},{"@type":"BreadcrumbList","@id":"https://www.cordeledispatch.com/2022/06/24/bruce-curtis-drennan/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.cordeledispatch.com/"},{"@type":"ListItem","position":2,"name":"Bruce Curtis Drennan"}]},{"@type":"Person","@id":"https://www.cordeledispatch.com/#/schema/person/434626653d9c0d573eee2a31cd093dec","name":"Chris Lewis","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.cordeledispatch.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/a24169d35a210594afebe5d10bfcdbca?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/a24169d35a210594afebe5d10bfcdbca?s=96&d=mm&r=g","caption":"Chris Lewis"},"url":"https://www.cordeledispatch.com/author/chris-lewis/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Cordele Dispatch &raquo; Bruce Curtis Drennan Comments Feed" href="https://www.cordeledispatch.com/2022/06/24/bruce-curtis-drennan/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.cordeledispatch.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://www.cordeledispatch.com/_static/??-eJx9jEEOwiAQRS8koDG16cJ4FgpjMzoMhBnScHtlZzcuX95/3+3FIAdqEcS9xCWI6IEgAesBCvkO1RBsPnSbkG0QObl/+df98iEKmXVsCrUNeYRaM4OaUvMTCUzBoK2CiyjqVsrhLVa0E9i1IcVx9Ej3y22alut5npcPRQVLEg==' type='text/css' media='all' />
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='all-css-2' href='https://www.cordeledispatch.com/_static/??-eJx1jUEOgzAMBD9Uk1YVRRyqviUkDrVkQsQGIX7fAKcicfFhZ3ZtlkQSnc6eYRxgvMVX3BhRDRKrktzMWbG+IOrs9KeUTuaYTdK5l4gtSqMqzH6paJfqBFBg9rSI7znvT5BX5csGZEjKhGxDIBUUMncq7qieIR1wW/sM78errtvnvWnaHwaWXYA=' type='text/css' media='all' />
<style id='admin-bar-inline-css'>
#wp-admin-bar-my-sites-search.hide-if-no-js {
	display: none;
}
#wp-admin-bar-my-sites-search label[for="my-sites-search-text"] {
	clip: rect(1px, 1px, 1px, 1px);
	position: absolute !important;
	height: 1px;
	width: 1px;
	overflow: hidden;
}
#wp-admin-bar-my-sites-search {
	height: 38px;
}
#wp-admin-bar-my-sites-search .ab-item {
	height: 34px;
}
#wp-admin-bar-my-sites-search input {
	padding: 0 2px;
	width: 95%;
	width: calc( 100% - 4px );
}
	
</style>
<style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.cordeledispatch.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='staff-list-custom-css-css'  href='https://www.cordeledispatch.com/wp-content/themes/2021-cordele-child/simple-staff-list-custom.css?ver=6.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://www.cordeledispatch.com/_static/??-eJyNj0sKwzAMRC9UR3Gg3pUepRhbOGr9I1IIuX2c0kI/m+w0I+kNA0tVrmTBLFDjHCgzLOQDiipVqDRpmVEYHP9uumad4AMgIyZkGPpBN2/yGFG5kaIHljXi332a1TvzjlKteyitux5S8XNsIB7thN56vz5HyuEw4kbZARdHNqpYQuEv0SXKh1F78Zex/1zTRZuzaR2NMRsepnOw' type='text/css' media='all' />
<script type="text/javascript" src="https://www.cordeledispatch.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZqbGlsaWFiUUWAK+/IjA=" ></script><script src='https://www.cordeledispatch.com/wp-content/plugins/trinity-audio/js/the_content-hook-script.js?ver=6.0' id='the_content-hook-script-js'></script>
<script id='the_content-hook-script-js-after'>
console.debug('TRINITY_WP', 'Skip player from rendering', 'is single: 1, is main loop: , is main query: 1', 'TS: 2022-06-25 02:46:20');
</script>
<link rel="https://api.w.org/" href="https://www.cordeledispatch.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.cordeledispatch.com/wp-json/wp/v2/posts/17847" /><link rel='shortlink' href='https://www.cordeledispatch.com/?p=17847' />
<link rel="alternate" type="application/json+oembed" href="https://www.cordeledispatch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cordeledispatch.com%2F2022%2F06%2F24%2Fbruce-curtis-drennan%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.cordeledispatch.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.cordeledispatch.com%2F2022%2F06%2F24%2Fbruce-curtis-drennan%2F&#038;format=xml" />
<link href="https://trinitymedia.ai/" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai/" rel="preconnect" crossorigin="anonymous" />
<style>img#wpstats{display:none}</style>
	<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-66905909-1', 'auto');
  ga('send', 'pageview');
</script>
								<script type="text/javascript">
          var $ = jQuery;
          var adm_dmm_id = '5f6282885c443b70829af413';
          var adm_dam_id = '5f62838dbb23623aed7b2951';
          var adm_dpm_id = '5f62836bda6fa904f9fb8905';
          var loggedin = false;
          window.admiral = window.admiral || function() {(admiral.q = admiral.q || []).push(arguments)};

					
          function setCookie() {
              window.admiral('after','measure.detected',function(user) {
                  var d = new Date();
                  d.setTime(d.getTime() + (7*24*60*60*1000));
                  var n = d.toUTCString();
                  if (user.subscribed) {
                      document.cookie = "bni_admiral_loggedin=1; expires=" + n + "; path=/";
                      loggedin = true;
                      return;
                  }
                  document.cookie = "bni_admiral_loggedin=0; expires=" + n + "; path=/";
                  window.sessionStorage.setItem('cfS', '0');
              })
          }
          window.onload = setCookie();

          function readCookie(c) {
              var a = document.cookie.split(';');
              for (var i = 0; i < a.length; i++) {
                  var b = a[i].split('=');
                  var d = b[0].trim();
                  if (c === d) {
                      var e = b[1].trim();
                      if (e === "1") {
                          loggedin = true;
                      } else {
                          loggedin = false;
                      }
                  }
              }
              return true;
          }
          window.onload = readCookie('bni_admiral_loggedin');
          window.admiral('after', 'transact.subscribed', function() {
              var x = window.sessionStorage.getItem('cfS');
              if (x === "1") {
                  return;
              }
              window.sessionStorage.setItem('cfS', '1');
              location.reload();
          })

          $(window).load(function() { // These functions get called when everything has loaded
            if (!loggedin) {
              $("#right_items_extra").prepend('<a href="#" onclick="window.admiral(&quot;show&quot;, &quot;transact.login&quot;,{offerID:&quot;' + adm_dmm_id + ',' + adm_dpm_id + ',' + adm_dam_id + '&quot;});" class="paywall_login">Log In</li>');
            } else {
              $("#subscribe_button").replaceWith('<a href="#" onclick="window.admiral(&quot;show&quot;, &quot;transact.manage&quot;);" class="subscribe">My Account</a>');
            }
            console.log('%c TESTING ADMIRAL V 2.1', 'background: #222; color: #bada55');
          });

          $( document ).ready(function() {
            // Digital Monthly Membership
            $('#adm_dmm').click(function(c) {
              c.preventDefault();
              window.admiral('show','transact.subscribe',{offerID:adm_dmm_id})
            });
            // Digital Annual Membership
            $('#adm_dam').click(function(c) {
              c.preventDefault();
              window.admiral('show','transact.subscribe',{offerID:adm_dam_id})
            });
            // Digital and Print Membership
            $('#adm_dpm').click(function(c) {
              c.preventDefault();
              window.admiral('show','transact.subscribe',{offerID:adm_dpm_id})
            });
          });
				</script>


				<script defer="defer" type="text/javascript" src="https://www.cordeledispatch.com/wp-content/themes/2021-bni/media/js/colorbox/jquery.colorbox-min.js"></script>
        <link href="https://www.cordeledispatch.com/wp-content/themes/2021-bni/media/js/colorbox/colorbox.css" rel="stylesheet">


        <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://gondolagnome.com/v2/0/xmuNDUImn6cukqoRAM56aVt3C_LNsGiP906O5PTpLDilJvL6HMc4aKZCulosKyq_FxDKXxFhfwMhqw",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;;</script>


                    <!-- DFP Work -->
    
        <script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>

        <link rel="stylesheet" type="text/css" href="https://htlbid.com/v3/cordeledispatch.com/htlbid.css" />
    <script src="https://htlbid.com/v3/cordeledispatch.com/htlbid.js"></script>
     
<script>
  window.googletag = window.googletag || {cmd: []};
  window.htlbid = window.htlbid || {};
  htlbid.cmd = htlbid.cmd || [];
  htlbid.cmd.push(function() {
          htlbid.setTargeting('is_testing', 'no');
      });

  // GPT ad slots
  var interstitialSlot;


googletag.cmd.push(function() {

    			googletag.defineSlot('/1613683/CRD-300x250-instory-third', [[300, 250], [1, 1]], 'div-gpt-ad-instory-third').addService(googletag.pubads());
			FEATUREDGALLERY_AD = googletag.defineSlot('/1613683/CRD-300x250-featured_gallery', [300, 250], 'div-gpt-ad-bigblock-featured_gallery').addService(googletag.pubads());

        if (!loggedin) {
			googletag.defineSlot('/1613683/CRD-1x1-2', [1,1], 'div-gpt-ad-extra_one_by_one').addService(googletag.pubads());
			googletag.defineSlot('/1613683/CRD-1x1-3', [1,1], 'div-gpt-ad-extra_oop').addService(googletag.pubads());
			googletag.defineSlot('/1613683/CRD-1x1-4', [1,1], 'div-gpt-ad-extra_one_by_one_two').addService(googletag.pubads());
  }
       

    			googletag.defineSlot('/1613683/CRD-300x250-1', [300, 250], 'div-gpt-ad-bigblock-1').addService(googletag.pubads());
			googletag.defineSlot('/1613683/CRD-300x250-2', [300, 250], 'div-gpt-ad-bigblock-2').addService(googletag.pubads());
			googletag.defineSlot('/1613683/CRD-300x250-3', [300, 250], 'div-gpt-ad-bigblock-3').addService(googletag.pubads());
			googletag.defineSlot('/1613683/CRD-300x250-4', [300, 250], 'div-gpt-ad-bigblock-4').addService(googletag.pubads());
			googletag.defineSlot('/1613683/CRD-300x250-5', [300, 250], 'div-gpt-ad-bigblock-5').addService(googletag.pubads());
			googletag.defineSlot('/1613683/CRD-300x250-12', [300, 250], 'div-gpt-ad-bigblock-12').addService(googletag.pubads());
			googletag.defineSlot('/1613683/CRD-300x250-13', [300, 250], 'div-gpt-ad-bigblock-13').addService(googletag.pubads());
			googletag.defineSlot('/1613683/CRD-300x250-18', [300, 250], 'div-gpt-ad-bigblock-18').addService(googletag.pubads());

			googletag.defineSlot('/1613683/CRD-300x600-1', [[300, 600], [160, 600]], 'div-gpt-ad-halfpage-1').addService(googletag.pubads());

      var large_leaderboard_one = googletag
        .defineSlot('/1613683/CRD-970x250-1', [[970, 90], [970, 250], [728, 90], [320, 50]], 'div-gpt-ad-largeleaderboard-one')
        .addService(googletag.pubads());
          var large_leaderboard_four = googletag
        .defineSlot('/1613683/CRD-970x250-4', [[970, 90], [970, 250], [728, 90], [320, 50]], 'div-gpt-ad-largeleaderboard-four')
        .addService(googletag.pubads());

      var leaderboard_mapping = googletag.sizeMapping()
        .addSize([970, 728], [[970, 250], [970, 90], [728, 90]])
        .addSize([320, 240], [320, 50])
        .addSize([0, 0], [])
        .build();

      large_leaderboard_one.defineSizeMapping(leaderboard_mapping);
          large_leaderboard_four.defineSizeMapping(leaderboard_mapping);

  if (!loggedin) {
      			googletag.defineSlot('/1613683/CRD-1x1-wall', [1,1], 'div-gpt-ad-one_by_one_wall').addService(googletag.pubads());
       
			googletag.defineOutOfPageSlot('/1613683/CRD-1x1-1', 'div-gpt-ad-screenshift').addService(googletag.pubads());

      // Define a web interstitial ad slot.
      interstitialSlot = googletag.defineOutOfPageSlot(
          '/1613683/CRD-interstitial',
          googletag.enums.OutOfPageFormat.INTERSTITIAL);

      // Slot returns null if the page or device does not support interstitials.
      if (interstitialSlot) {
        interstitialSlot.addService(googletag.pubads());
      }
	  }

  if (loggedin) {
        googletag.defineOutOfPageSlot('/1613683/CRD-sub-1x1-1', 'div-gpt-ad-screenshift').addService(googletag.pubads());
  }


                          googletag.pubads().setTargeting("catname", [ "obituaries",  ]);
                        


          googletag.pubads().setTargeting("pageurl", "/2022/06/24/bruce-curtis-drennan/");
    
    
		googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs()
    googletag.pubads().disableInitialLoad();
    googletag.enableServices();

});


</script>


        
	                  <script defer="defer" type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
      


          </head>
		<body id="articlePage" class="">
        <!--[if lt IE 7]>
            <p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to improve your experience.</p>
        <![endif]-->
        																<!-- Paste this after your <body> tag. Fill in "ARTICLE_URL" and "CONTENT_ID" --> 
				<script type="text/javascript"> 
				(function() { 
					var ARTICLE_URL = 'https://www.cordeledispatch.com/2022/06/24/bruce-curtis-drennan/'; 
					var CONTENT_ID = ''; // Optional or leave empty 
					document.write( 
						'<scr'+'ipt '+ 
						'src="//survey.g.doubleclick.net/survey?site=_xwfdnfpun2yotjcjjlkbvqsp6u'+ 
						'&amp;url='+encodeURIComponent(ARTICLE_URL)+ 
						(CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+ 
						'&amp;random='+(new Date).getTime()+ 
						'" type="text/javascript">'+'\x3C/scr'+'ipt>'); 
          })(); 

          jQuery(document).ready(function() { // These functions get called on DOM ready
						if (!loggedin) {
							load_402_show_function();
						}
          });
				</script> 
				

				<div id="" class="undertone">

            <div id="sup_nav" class="sup_nav single">
    <div class="wrapper">
      <div id="logo">
        <a href="https://www.cordeledispatch.com" class="desktop">
          <img data-perfmatters-preload src="https://www.cordeledispatch.com/wp-content/themes/2021-cordele-child/media/img/brand/logo-white-cordeledispatch.png" alt="Cordele Dispatch" />
        </a>
        <a href="https://www.cordeledispatch.com" class="mobile">
          <img data-perfmatters-preload src="https://www.cordeledispatch.com/wp-content/themes/2021-cordele-child/media/img/brand/logo-white-mobile-cordeledispatch.png" alt="Cordele Dispatch" />
        </a>
      </div>
      <div class="right_items">
        <div class="share_buttons_group">
        <div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-17847" class="share-facebook sd-button share-icon no-text" href="https://www.cordeledispatch.com/2022/06/24/bruce-curtis-drennan/?share=facebook" target="_blank" title="Click to share on Facebook" ><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-17847" class="share-twitter sd-button share-icon no-text" href="https://www.cordeledispatch.com/2022/06/24/bruce-curtis-drennan/?share=twitter" target="_blank" title="Click to share on Twitter" ><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="mailto:?subject=%5BShared%20Post%5D%20Bruce%20Curtis%20Drennan&body=https%3A%2F%2Fwww.cordeledispatch.com%2F2022%2F06%2F24%2Fbruce-curtis-drennan%2F&share=email" target="_blank" title="Click to email a link to a friend" data-email-share-error-title="Do you have email set up?" data-email-share-error-text="If you&#039;re having problems sharing via email, you might not have email set up for your browser. You may need to create a new email yourself." data-email-share-nonce="0e2d0e5f29" data-email-share-track-url="https://www.cordeledispatch.com/2022/06/24/bruce-curtis-drennan/?share=email"><span></span><span class="sharing-screen-reader-text">Click to email a link to a friend (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.cordeledispatch.com/2022/06/24/bruce-curtis-drennan/#print" target="_blank" title="Click to print" ><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>        </div>
        <div id="right_items_extra">
        <span id="subscribe_button"><a href="/subscriptions/" class="subscribe">Subscribe</a></span>        </div>
      </div>
    </div>
    <nav role="navigation">
      <div class="wrapper">
        <div id="menuToggle">
          <input type="checkbox" />
          <span></span>
          <span></span>
          <span></span>
          
	
        <ul id="menu-main" class="menu"><li id="menu-item-17057" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-17057"><a href="https://www.cordeledispatch.com/">Home</a></li>
<li id="menu-item-17058" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17058"><a href="https://www.cordeledispatch.com/category/news/">News</a></li>
<li id="menu-item-17059" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17059"><a href="https://www.cordeledispatch.com/category/sports/">Sports</a></li>
<li id="menu-item-17060" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17060"><a href="https://www.cordeledispatch.com/category/opinion/">Opinion</a></li>
<li id="menu-item-17061" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17061"><a href="https://www.cordeledispatch.com/category/columns/">Columns</a></li>
<li id="menu-item-17062" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17062"><a href="https://marketplace.cordeledispatch.com/AdHunter/cordele">Classifieds</a></li>
<li id="menu-item-17063" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17063"><a href="https://www.cordeledispatch.com/category/obituaries/">Obits</a></li>
<li id="menu-item-17064" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17064"><a href="https://www.cordeledispatch.com/best-of-crisp/">Best of Crisp</a></li>
<li id="menu-item-17065" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17065"><a href="https://www.cordeledispatch.com/services/about-us/">About Us</a></li>
<li id="menu-item-17066" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17066"><a href="https://marketplace.cordeledispatch.com/AdHunter/cordele/Home/Search?majorClass=2600">Public Notices</a></li>
<li id="menu-item-17067" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17067"><a href="https://subscriptions.cordeledispatch.com/CircStore/Account/Login?vendor=DirXion&#038;prodId=CD">E-Edition</a></li>
<li class="search_bar"> <form id="search_bar" action="https://www.cordeledispatch.com/site-search/" class="search_bar_form" method="get" tabindex="0"> <img data-perfmatters-preload src="https://www.cordeledispatch.com/wp-content/themes/2021-bni/media/img/Search_icon-black.png" width="30" height="30" /> <input type="text" name="q" class="searchQuery" placeholder="Search Cordele Dispatch..." value="" /> <input type="submit" class="searchButton" value="Go" /> </form> </li></ul>
        </div>
      </div>
    </nav>
  </div>

					<div id="main_body" class="wrapper">
         
        <!-- SCREENSHIFT -->
<div id='div-gpt-ad-screenshift'>
  <script>
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-screenshift');
    });
  </script>
</div> 

						<div id="content" class="flownews">
							<div id="notifications">
																
																							</div>

        <div class="ad mobile_sticky_top">
          <div class="large_leaderboard"><!-- ROS_970x250-1 -->
<div id='div-gpt-ad-largeleaderboard-one'>
  <script>
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-largeleaderboard-one');
    });
  </script>
</div></div>
        </div>


  <div class="one_by_one_group">
  <!-- one_by_one_wall-->
<div id='div-gpt-ad-one_by_one_wall'>
  <script>
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-one_by_one_wall');
    });
  </script>
</div>  </div>
 

	  <div class="page_type-story">
  
  <div class="main_column">
    <div class="story">
      
      

      <div id="article">

<!-- READY FOR OPT VIDEO -->

        <h2 class="headline">Bruce Curtis Drennan</h2>

        <p class="pubStamp">Published 4:43 pm Friday, June 24, 2022</p>

        <div class="byline">
          
          <p class="author">
	            <strong>By <a href="https://www.cordeledispatch.com/author/chris-lewis/" rel="bookmark">Chris Lewis</a></strong>

                      </p>
                    <div class="clearfix"></div>
        </div><!-- END BYLINE -->

        

        <div class="story_grid">
          <div class="story_detail">

            <div class="one_by_one_group">
              <!-- extra_one_by_one -->
<div id='div-gpt-ad-extra_one_by_one'>
  <script>
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-extra_one_by_one');
    });
  </script>
</div>              <!-- extra_one_by_one_two -->
<div id='div-gpt-ad-extra_one_by_one_two'>
  <script>
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-extra_one_by_one_two');
    });
  </script>
</div>              <!-- extra_oop -->
<div id='div-gpt-ad-extra_oop'>
  <script>
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-extra_oop');
    });
  </script>
</div>            </div>

              <div class="gallery_group">
      <div id="story_photo_group">
        
                                    

              </div>
    </div>

            <div class="p402_premium">
            
        <table id="trinity-audio-table" style="width:100%; display: table;">
            <tr>
                <td id="trinity-audio-tab" style="border: none;">
                    <div id="trinity-audio-player-label"></div>
                    <script nitro-exclude data-trinity-mount-date='2022-06-25 02:46:20'>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</script><div class='trinityAudioPlaceholder' data-trinity-mount-date='2022-06-25 02:46:20'></div>
                </td>
            </tr>
        </table><p>Bruce Curtis Drennan, (The Great Santini, Bossman, Grandpa, Dad, Brucey) died on Thursday, June 23, 2022 after threatening his children he would do so for quite some time. Funeral services to celebrate his truly unique and full life will be held on Sunday, June 26, 2022 at 2:00 p.m. in the chapel of Rainey Family Funeral Services. He will be buried at Sunnyside Cemetery with Military Honors following the service. His children, grandchildren, and family will be at the funeral home on Saturday June 25<sup>th</sup> from 5:00-7:00 p.m. to laugh, cry, tell stories about their dad, and to hear new ones from his friends they haven’t heard before.<br />
Bruce was born on October 10, 1947 in Pineville, Louisiana and was adopted by Charles Curtis Drennan and his bride, Gwendolyn Ruth Ballinger, whom he met in England and married after the war. His childhood taught him the value of hard work and overcoming adversity. He was especially close to his father, and he worked with him in the service station, small engine repair shop, and trailer park his family owned and operated. His dad affectionately referred to him at ‘Butch.’<br />
Eventually Bruce ended up in Bossier City, Louisiana where he met his future wife Sandra Lynne Sheppard at their High School Graduation Party. Over the next few years, Bruce started college at Northwestern University in Louisiana, married Sandy, and enlisted in the Air Force where he served in the Vietnam Conflict. After his enlistment was over, Bruce and Sandy moved to Cordele, Georgia where they both graduated from Georgia Southwestern College. After college Bruce was commissioned an Ensign in the United Sates Navy. Over the next 20+ years Bruce and Sandy lived the Navy life in Milton, FL, Ft. Walton Beach, FL, Jacksonville, FL, Fairfax, VA, Prattville, AL, Washington, D.C., and Tampa, FL with countless deployments and one epic stunt where Bruce left a pregnant Sandy at home, who went into labor while he was rounding the tip of South America on the USS Scott. While in the military, Bruce completed his MBA at Central Michigan University and studied Foreign Affairs at The Air Force War College. Along the way, they collected memories, several Siamese cats, a love of the water and boating, oh yeah and three children. After retiring from the Navy in 1995, Bruce began his second career in community and economic development eventually moving ‘home’ to Cordele, Georgia. He was proud of his work as the Executive Director of the Cordele-Crisp Industrial Development Council and the relationships he built while working there. Not one to relish the spotlight, Bruce was beyond proud when he was named one of Georgia’s ‘100 Most Influential Georgians’ in 2013 by Georgia Trend Magazine.<br />
Bruce and Sandy were at their happiest on the water. They loved living on Lake Blackshear and taking their boat, ‘Lagniappe’ out for a spin or over to Cypress Grill for lunch. Through their travels on the Florida coast, they fell in love with a little forgotten fishing village, Carrabelle, and eventually put down roots there as well, which led to the need for another boat, ‘Innisfree.’ One of the happiest events in Bruce’s adult life was finding his biological family and discovering that he had a brother and sister. He and Sandy both became very close with his sister, Linda, and cherished the time and relationship they had together until her death.<br />
Bruce’s three children are still not convinced that he wasn’t abducted by aliens and replaced with a look alike right around the time he became a grandfather. Suddenly the stern disciplinarian from their childhood with a penchant for surprise closet inspections seemed to abandon rules altogether. All bets were off when it came to his four grandsons, and he took pride in buying them every video game, toy, power-wheel, and gadget they could dream up. He especially enjoyed finding the loudest, most annoying toy possible for birthdays and Christmas, gifting it to one of the boys, and then sending them home along with extra batteries for their parents to ‘enjoy.’ Bruce finally got a granddaughter in his last years and we are pretty certain that she never did anything wrong in his eyes.<br />
For Bruce, love was more about what you did than what you said. He showed his family how much he loved them through his hard work, the experiences he provided them, and the way he was always there for them no matter how bad they had messed up. His love for his wife, Sandy, was one for the ages. After losing her in 2016, he was just never the same and his family is at peace knowing that they are once again together.<br />
Bruce was preceded in death by his parents, his wife Sandra, and his sister Linda Core Al Alawi. He was father to Jane Cameron Bedore, Johanna Rebekah (Jack) Masters, and Benjamin Bruce (Liz) Drennan, grandfather to Andrew Cameron Bedore, Johnathan Patrick Bedore, Matthew Thomas Bedore, Isaac Benjamin Drennan, and Emilee Masters, and brother to Jim (Pat) Reed of Denham Springs, LA. Arrangements are by Rainey Family Funeral Services. An online register book is available at <a href="http://www.raineyfuneral.com/" data-saferedirecturl="https://www.google.com/url?q=http://www.raineyfuneral.com&amp;source=gmail&amp;ust=1656189477765000&amp;usg=AOvVaw0bxs6J6SiqSX_I5Tm2BnoY">www.raineyfuneral.com</a></p>
<p>
<div class="ad count3"><div id='div-gpt-ad-bigblock-1'>
  <script>
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-1');
    });
  </script>
</div></div><div class="instory_widget"></div><div class="ad"><div id='div-gpt-ad-bigblock-2'>
  <script>
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-2');
    });
  </script>
</div></div><div class="ad"><div id='div-gpt-ad-bigblock-instory-third'>
  <script>
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-instory-third');
    });
  </script>
</div></div><div id="cedato-unit"></div><div class="ad"><div id='div-gpt-ad-bigblock-3'>
  <script>
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-3');
    });
  </script>
</div></div>            </div><!-- END p402_premium (GOOGLE SURVEY) -->
            <script type="text/javascript">
               var load_402_show_function = function () { try { _402_Show(); } catch(e) { } }
            </script>

            <div id="comments"> </div><!-- END comments -->
            
                                  


              <div id="NTV_1"></div>

            
<div class="more_to_explore">
  <h4>More Obituaries</h4>
  
        <div class="story">
                    <h3><a href="https://www.cordeledispatch.com/2022/06/22/mrs-kathy-brock-parsons/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" rel="bookmark" title="Mrs. Kathy Brock Parsons">Mrs. Kathy Brock Parsons</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <h3><a href="https://www.cordeledispatch.com/2022/06/22/wylene-wynn-maddox/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" rel="bookmark" title="Wylene Wynn Maddox">Wylene Wynn Maddox</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <h3><a href="https://www.cordeledispatch.com/2022/06/22/joann-mcglamry-irvine/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" rel="bookmark" title="JoAnn McGlamry Irvine">JoAnn McGlamry Irvine</a></h3>

          <div class="clearfix"></div>
        </div>

        
        <div class="story">
                    <h3><a href="https://www.cordeledispatch.com/2022/06/14/donnie-b-paramore/?utm_source=site&utm_medium=organic&utm_campaign=recirculation" rel="bookmark" title="Donnie B. Paramore">Donnie B. Paramore</a></h3>

          <div class="clearfix"></div>
        </div>

        
</div>

              <div id="prev_next_article_group" class="prev_next_article">
  <!-- v 1.61 -->
          <div class="prev_article">
        <div class="padding">
          <a href="https://www.cordeledispatch.com/2022/06/22/mrs-kathy-brock-parsons/" class="arrow left button">
            <svg width="30px" height="30px" viewBox="0 0 50 80" xml:space="preserve">
              <polyline fill="none" stroke="#000000" stroke-width="1" stroke-linecap="round" stroke-linejoin="round" points="
            45.63,75.8 0.375,38.087 45.63,0.375 "/>
            </svg>  
          </a>
        </div>
      </div>
    
                      <div class="next_article">
        <div class="padding">
          <div class="label">You Might Like</div>
                    <h4> <a href="https://www.cordeledispatch.com/2022/06/22/mrs-kathy-brock-parsons/">Mrs. Kathy Brock Parsons</a> </h4>
          <a href="https://www.cordeledispatch.com/2022/06/22/mrs-kathy-brock-parsons/" class="arrow right button">
            <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="30px" height="30px" viewBox="0 0 50 80" xml:space="preserve">
              <polyline fill="none" stroke="#000000" stroke-width="1" stroke-linecap="round" stroke-linejoin="round" points="
            0.375,0.375 45.63,38.087 0.375,75.8 "/>
            </svg>
          </a>
        </div>
      </div>
        <div class="clearfix"></div>
  </div>


            
											<div class="print_this bubble_buttons">
													<a href="#">Print Article</a>
											</div><!-- END print_this -->


            <div class="articleOptions bubble_buttons">
              <div class="admin">
</div>
<div class="clearfix"></div>


            </div>

                        
              



	
<div class="one_by_one_group">
<div id="rev_video"></div>
</div>



            
            </div><!-- END STORY_DETAIL -->

            <div class="sidebar">
                  
<ul class="sidebar">
	<li>
		<div class="ad ">
			<div id='div-gpt-ad-bigblock-12'>
  <script>
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-12');
    });
  </script>
</div>		</div>
	</li>
			<li>
		<div class="ad">
			<div id='div-gpt-ad-bigblock-13'>
  <script>
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-13');
    });
  </script>
</div>		</div>
	</li>
		<li>
		<div class="story_list widget">
			<ul>
							</ul>
		</div>
	</li>
		<li>
		<div class="ad">
			<div id='div-gpt-ad-bigblock-18'>
  <script>
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-bigblock-18');
    });
  </script>
</div>		</div>
	</li>
	  </ul>
    <div class="sticky">
      <div class="ad">
        <div id='div-gpt-ad-halfpage-1'>
  <script>
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-halfpage-1');
    });
  </script>
</div>      </div>
    </div>            </div>
            <div class="right_rule"></div>
        </div>

    </div>
  </div>

</div>

  

	<div class="clearfix"></div>
    <div id="mobile_sticky_bottom_group" class="ad mobile_sticky_bottom">
      <div class="large_leaderboard"><!-- ROS_970x250-4 -->
<div id='div-gpt-ad-largeleaderboard-four'>
  <script>
    htlbid.cmd.push(function() {
      htlbid.display('div-gpt-ad-largeleaderboard-four');
    });
  </script>
</div></div>
    </div>
					</div>
					<div id="footer" class="clearfix">
            <div class="wrapper">
              <div id="footSections" class="col">
	                <h4>Sections</h4>
                <ul id="menu-footer-sections" class="menu"><li id="menu-item-17068" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-17068"><a href="https://www.cordeledispatch.com/">Home</a></li>
<li id="menu-item-17069" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17069"><a href="https://www.cordeledispatch.com/category/news/">News</a></li>
<li id="menu-item-17070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17070"><a href="https://www.cordeledispatch.com/category/sports/">Sports</a></li>
<li id="menu-item-17071" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17071"><a href="https://www.cordeledispatch.com/category/opinion/">Opinion</a></li>
<li id="menu-item-17072" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17072"><a href="https://www.cordeledispatch.com/category/columns/">Columns</a></li>
<li id="menu-item-17073" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17073"><a href="https://www.cordeledispatch.com/category/lifestyle/">Lifestyles</a></li>
<li id="menu-item-17074" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17074"><a href="https://marketplace.cordeledispatch.com/AdHunter/cordele">Classifieds</a></li>
<li id="menu-item-17075" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17075"><a href="https://www.cordeledispatch.com/category/obituaries/">Obits</a></li>
<li id="menu-item-17076" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17076"><a href="https://smb.cordeledispatch.com/">Small Business</a></li>
</ul>              </div>


              <div id="footServices" class="col">
	                <h4>Services</h4>
                <ul id="menu-footer-services" class="menu"><li id="menu-item-17077" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17077"><a href="https://www.cordeledispatch.com/services/about-us/">About Us</a></li>
<li id="menu-item-17078" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17078"><a href="https://www.cordeledispatch.com/services/policies/">Policies</a></li>
<li id="menu-item-17079" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17079"><a href="https://www.cordeledispatch.com/services/policies/#termsofuse">Terms of Use</a></li>
</ul>              </div>


              <div id="footCopyright" class="col">
                                <h4>Copyright</h4>
                <ul>
                  <li>&copy; 2022, Cordele Dispatch</li>
                </ul>

              </div>
            </div>

					</div>
				</div>


				        <script defer="defer" src="https://cdn.jsdelivr.net/bxslider/4.2.12/jquery.bxslider.min.js"></script>
        <script defer="defer" src="https://www.cordeledispatch.com/wp-content/themes/2021-bni/media/js/vendors/jquery.contentcarousel.js?1655930780"></script>
        <script defer="defer" src="https://www.cordeledispatch.com/wp-content/themes/2021-bni/media/js/vendors/jquery.easing.1.3.js"></script>
				<script defer="defer" src="https://www.cordeledispatch.com/wp-content/themes/2021-bni/media/js/vendors/jquery.timeago.js"></script>
        <script defer="defer" src="https://www.cordeledispatch.com/wp-content/themes/2021-bni/media/js/plugins.js?1655930780"></script>
        <script defer="defer" src="https://www.cordeledispatch.com/wp-content/themes/2021-bni/media/js/main.js?1655930780"></script>

        
				
<script type="text/javascript">tb_pathToImage = "https://www.cordeledispatch.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "https://www.cordeledispatch.com/wp-includes/js/thickbox/tb-close.png";</script>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.cordeledispatch.com\/2022\/06\/24\/bruce-curtis-drennan\/":17847};
	</script>
				<script type="text/javascript" src="https://www.cordeledispatch.com/_static/??/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js,/wp-includes/js/hoverintent-js.min.js?m=1655930779j" ></script><script src='https://www.cordeledispatch.com/wp-includes/js/admin-bar.min.js?ver=6.0' id='admin-bar-js'></script>
<script id='admin-bar-js-after'>
jQuery(document).ready( function($) {
	$('#wp-admin-bar-my-sites-search.hide-if-no-js').show();
	$('#wp-admin-bar-my-sites-search input').keyup( function( ) {
		var searchValRegex = new RegExp( $(this).val(), 'i');
		$('#wp-admin-bar-my-sites-list > li.menupop').hide().filter(function() {
			return searchValRegex.test( $(this).find('> a').text() );
		}).show();
	});
});
</script>
<script id='wp-polls-js-extra'>
var pollsL10n = {"ajax_url":"https:\/\/www.cordeledispatch.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
</script>
<script id='rfw-script-js-extra'>
var rfw = {"speed":""};
</script>
<script type="text/javascript" src="https://www.cordeledispatch.com/_static/??-eJyVizEOgzAMAD/UYKoKEEPFY4iDbAUnYKcRv2/LzMJyw+kOanZzEkMxyLEsJAo/lVOMCicda8P6gItwV3UB0btKfkEDVghFZqMkdx7eCu5HE8g+5P/jtL6ffdeNr3YYRv4Cu9k8Bg==" ></script><script nitro-exclude data-wpfc-render='false' data-trinity-mount-date='2022-06-25 02:46:20' src='https://trinitymedia.ai/player/trinity/323c303cabbf6114f775bec959b9430a/?postHash=1e2dbcd3165ace283e4570794efa58fa&#038;poweredby=1&#038;language=en-US&#038;voiceGender=m&#038;pageURL=https%3A%2F%2Fwww.cordeledispatch.com%2F2022%2F06%2F24%2Fbruce-curtis-drennan%2F&#038;ver=6.0' id='trinity-player-js'></script>
<script id='sharing-js-js-extra'>
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
</script>
<script src='https://www.cordeledispatch.com/wp-content/mu-plugins/jetpack-11.0/_inc/build/sharedaddy/sharing.min.js?ver=11.0' id='sharing-js-js'></script>
<script id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
</script>
<script src='https://stats.wp.com/e-202225.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.0',blog:'177045789',post:'17847',tz:'-4',srv:'www.cordeledispatch.com',hp:'vip'} ]);
	_stq.push([ 'clickTrackerInit', '177045789', '17847' ]);
</script>
				</div><!-- END undertone -->
        				<script defer="defer" id="dsq-count-scr" src="//cordeledispatch.disqus.com/count.js" async></script>
        
                <script>
document.addEventListener("DOMContentLoaded", function() {
  htlbid.cmd.push(() => {
    htlbid.refresh();
  });  
});
</script>
        
    </body>
</html>